Instalar Drush Vía Composer en Ubuntu 14.04

Composer es un gestor de dependencias para proyectos.
En concreto para el lenguaje PHP.

Página del proyecto:

https://getcomposer.org/

Instalar Drush por medio de Composer es muy útil por varios motivos.
Uno de ellos es que te permite que versión de Drush quieres instalar.
Si por ejemplo quieres utilizar la versión 7 de Drush la cual es la recomendada para Drupal 8 no tienes problemas con Composer.

Así que vamos a ver como lo podemos lograr en Ubuntu, probado en la versión 14.04.

Tienes que tener primero instalados los siguientes paquetes:

sudo apt-get install curl git snmp -y

Descargar Composer en Ubuntu

Para obtener Composer lo puedes hacer abriendo una terminal y ingresando lo siguiente:

cd ~/
curl -sS https://getcomposer.org/installer | php

Descargar Composer

Esto te descarga un archivo llamado composer.phar en tu directorio raíz de tu usuario.

Ahora tenemos que ubicarlo para poder utilizarlo luego.

sudo mv composer.phar /usr/local/bin/composer

Añadiendo Composer al PATH

Para poder utilizarlo de manera global (esto es para no ir hasta /usr/local/bin/composer) tenemos que decirle a nuestro sistema que si lo ejecutamos desde otro lado lo busque en la siguiente ruta.

Por tanto editamos el archivo llamado .bashrc

sudo nano ~/.bashrc

Y al final ponemos lo siguiente:

#Composer
PATH=$PATH:~/.composer/vendor/bin

Guardamos los cambios con F2 y luego Enter.

Tenemos que actualizar los cambios así que en la consola hacemos:

source ~/.bashrc

Ahora ya tenemos todo listo para descargar Drush.

Descargar Drush con Composer

Una vez instalado Composer y agregado la ruta al PATH podemos descargar Drush.

Lo hacemos con:

composer show drush/drush

Ver la versiones disponibles de Drush

Esto me muestra todos las versiones disponibles que tiene de Drush.

Si lo que quiero es descargar la versión 7 la cual se encuentra en desarrollo y todavía no es estable hago:

composer global require drush/drush:dev-master

Instalar Drush con Composer

Si en cambio deseas otra versión lo puedes hacer con:

composer global require drush/la-versión-deseada

Eso es todo ahora ya tienes Drush instalado vía Composer.

Calificar: 
5

Premium

Landing Page con Bootstrap

Landing Page con Bootstrap y Gulp

En Youtube

Suscríbete a mi canal

Suscríbete a las noticias

* requerido

Inicio de sesión

Recursos